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Exercises using Satellite ToolKit (STK)
vivarad@ait.ac.th

Creating Satellite Orbits

1. What You Will Do

• Create a low-Earth orbit (LEO) satellite
• Create a medium-Earth orbit (MEO) satellite
• Create a highly elliptical orbit (HEO) satellite
• Create a geosynchronous orbit (GEO) satellite
• Observe differences among orbit types

2. What You Will Learn

In this exercise you'll learn to use the Keplerian Elements - a set of six parameters that determine the
size, shape and orientation of an orbit and the position of a satellite in that orbit at a given epoch (time).
The six elements are grouped into three subsets:

• Two elements that determine orbit size and shape
• Three elements that determine orbit orientation
• One element that determines satellite location

2.1 Orbit Size & Shape (2 Elements)

The two elements that determine orbit size and shape are linked; the parameter you use to specify the
first element determines the type of parameter (but not the value) you must use to specify the second.
The following pairs of elements are available:

First Element Second Element

semimajor axis eccentricity

apogee radius perigee radius

apogee altitude perigee altitude

period eccentricity

mean motion eccentricity

The parameters are defined as follows:

Parameter Definition

Semimajor Axis Half the distance between the two points in the orbit that are farthest apart

Apogee/Perigee
Radius

Measured from the center of the Earth to the points of maximum and
minimum radius in the orbit

Apogee/Perigee
Altitude

Measured from the "surface" of the Earth (a theoretical sphere with a radius
equal to the equatorial radius of the Earth) to the points of maximum and
minimum radius in the orbit

Period The duration of one orbit, based on assumed two-body motion

Mean Motion
The number of orbits per solar day (86,400 sec/24 hour), based on
assumed two-body motion

Eccentricity
The shape of the ellipse comprising the orbit, ranging between a perfect
circle (eccentricity = 0) and a parabola (eccentricity = 1)
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These and other parameters are illustrated in Figure 1.

Figure 1. Parameters determining orbit size and shape

Note: If eccentricity is zero, the Earth is at the center of the ellipse and the orbit
is circular.

2.2 Orbit Orientation (3 Elements)

After specifying the size and shape of the orbit, you must determine the orientation of the orbit plane in
space. Three Keplerian elements, represented by the following parameters, are involved:

• Inclination
• Right ascension or longitude of the ascending node

• Argument of perigee

The parameters are defined as follows:

Parameter Definition

Inclination
The angle between the orbital plane and the Earth's equatorial
plane (commonly used as a reference plane for Earth satellites)

Right Ascension of the
Ascending Node

The angle in the Earth's equatorial plane measured eastward from
the vernal equinox to the ascending node of the orbit

Argument of Perigee
The angle, in the plane of the satellite's orbit, between the
ascending node and the perigee of the orbit, measured in the
direction of the satellite's motion

Longitude of the
Ascending Node

The Earth-fixed longitude of the ascending node
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The ascending node (referenced in three of the above definitions) is the point in the satellite's orbit where
it crosses the Earth's equatorial plane going from south to north. Other definitions can be found in Figure
2:

Figure 2. Parameters determining orbit orientation

2.3 Satellite Location (1 Element)

To specify the satellite's location within its orbit at epoch, use one of the following parameters:

Parameter Definition

True Anomaly
The angle from the eccentricity vector (points toward perigee) to
the satellite position vector, measured in the direction of satellite
motion and in the orbit plane.

Mean Anomaly
The angle from the eccentricity vector to a position vector where
the satellite would be if it were always moving at its angular rate.

Eccentric Anomaly

An angle measured with an origin at the center of an ellipse from
the direction of perigee to a point on a circumscribing circle from
which a line perpendicular to the semimajor axis intersects the
position of the satellite on the ellipse.

Argument of Latitude The sum of the True Anomaly and the Argument of Perigee.

Time Past Ascending
Node

The elapsed time since the last ascending node crossing.

Time Past Perigee The elapsed time since last perigee passage.

Examples of true and eccentric anomalies are shown in Figure 3.
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Figure 3. Parameters determining satellite position

2.4 Setting the Keplerian Elements

In STK, the six Keplerian elements are found on the Basic/Orbit page of the satellite's Properties
Browser, on the right side of the window below the horizontal divider line. Four of the elements are
represented with drop-down lists, allowing for selection among two or more parameters. When you select
a parameter for the first element, the appropriate parameter for the second element appears
automatically in the second field.
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Activity 1: Create a Low-Earth Orbit (LEO) Satellite

Defining a Satellite

1. From the Insert Menu, click New..., select the Satellite icon from the Object Catalog, and click
Insert. If the Orbit Wizard appears, click Cancel to dismiss it. Name the new satellite LEO.

2. With the LEO satellite highlighted in the Object Browser, right-click and open it's Properties
Browser.

3. On the Basic/Orbit page, set the following parameters:

Note: Click the down-pointing arrow to the right of the Semimajor Axis field to
change the parameter type for the first Keplerian element to Period

Field Value

Propagator J4 Perturbation

Start Time 1 Jan 2000 00:00:00.00

Stop Time 2 Jan 2000 00:00:00.00

Step Size 1 minute

Orbit Epoch 1 Jan 2000 00:00:00.00

Coordinate Type Classical

Coordinate System J2000

Period 90 minutes

Eccentricity 0.0

Inclination 28.5 deg

Argument of Perigee 0.0 deg

RAAN 0.0 deg

True Anomaly 0.0 deg

4. When you finish, click OK. The orbit's ground track is displayed in the 2D Map window.

A Low-Earth Orbit (LEO)

By selecting a relatively short period (90 minutes), we have generated a satellite in low-Earth orbit (LEO).
A typical LEO is elliptical or, more often, circular, with a height of less than 2000 km above the surface of
the Earth. The orbit period at those altitudes ranges between 90 minutes and two hours. The radius of the
footprint of a communications satellite in LEO ranges between 3000 and 4000 km. The maximum time
during which a satellite in LEO is above the local horizon for an observer on the Earth is 20 minutes. A
global communications system using this type of orbit requires a large number of satellites, in a number of
different orbital planes. When a satellite serving a particular user moves below the local horizon, it must
hand over its duties to a succeeding one in the same orbit or in an adjacent one. Due to the comparatively
great movement of a satellite in LEO relative to an observer on the Earth, satellite systems using this type
of orbit must cope with large Doppler shifts. Satellites in LEO are also affected by atmospheric drag that
causes the orbit to gradually deteriorate

Examples of major LEO systems are GlobalstarTM (48+8 satellites in 8 orbital planes at 1400 km) and
Iridium® (66+6 satellites in 6 orbital planes at 780 km). There are also a number of small LEO systems,
such as PoSat, built by SSTL in 1993 and launched into an 822 by 800 km orbit, inclined at 98.6 deg.
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Activity 2: Create a Medium-Earth Orbit (MEO) Satellite

Defining a Satellite

1. Insert a new satellite. If the Orbit Wizard appears, dismiss it. Name the satellite MEO.

2. With the MEO satellite highlighted in the Object Browser, right-click and open it's Properties
Browser.

3. On the Basic/Orbit page, set the following parameters:

Note: Click the down-pointing arrow to the right of the Semimajor Axis field to
change the parameter type for the first Keplerian element to Apogee Altitude.

Field Value

Propagator J4 Perturbation

Start Time 1 Jan 2000 00:00:00.00

Stop Time 2 Jan 2000 00:00:00.00

Step Size 1 minute

Orbit Epoch 1 Jan 2000 00:00:00.00

Coordinate Type Classical

Coordinate System J2000

Apogee Altitude 10,000 km

Perigee Altitude 10,000 km

Inclination 15 deg

Argument of Perigee 0.0 deg

RAAN 0.0 deg

True Anomaly 0.0 deg

When you finish, click OK. The orbit's ground track is displayed in the 2-D Map window.

A Medium-Earth Orbit (MEO)

By setting the altitude parameters at 10,000 km, you generated a medium-Earth orbit (MEO). This one
happens to be an Intermediate Circular Orbit (ICO), since the apogee and perigee are equal. Its orbit
period measures about seven hours. The maximum time during which a satellite in MEO orbit is above the
local horizon for an observer on the Earth is a few hours. A global communications system using this type
of orbit requires relatively few satellites in two to three orbital planes to achieve global coverage. MEO
systems operate similarly to LEO systems. In MEO systems, however, hand-over is less frequent, and
propagation delay and free space loss are greater. Examples of MEO (specifically ICO) systems are
Inmarsat-P (10 satellites in 2 inclined planes at 10,355 km), and Odyssey (12 satellites in 3 inclined
planes, also at 10,355 km).

Note: To verify that the orbit period is about seven hours, set the parameter
type of the first element to Period. The parameter type of the second element
switches to Eccentricity, with a value of 0 (since the orbit is circular).
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Activity 3: Create a Highly Elliptical Orbit (HEO) Satellite

Defining a Satellite

1. Create a new satellite. If the Orbit Wizard appears, click Next to proceed to the next window.

Hint: If the Orbit Wizard doesn't appear automatically, make sure the new
satellite is highlighted in the Object Browser, then right-click and select Orbit
Wizard from the Tools menu.

2. In the Orbit Selection list, select Molniya. Click Next twice to proceed to the fourth window, then
click Finish to propagate the orbit.

3. Name the satellite HEO.

A Highly Elliptical Orbit (HEO)

A satellite in HEO typically has a perigee at about 500 km above the surface of the Earth and an apogee
as high as 50,000 km. The orbit is usually inclined at 63.4 deg to provide communications services to
locations at high northern latitudes. This inclination value is selected to avoid rotation of the apses; thus,
a line from the Earth's center to the apogee always intersects the Earth's surface at a latitude of 63.4 deg
North. Orbit period varies from eight to 24 hours. Owing to the high eccentricity of the orbit, a satellite
spends about two-thirds of the orbital period near apogee, during which time it appears to be almost
stationary to an observer on the Earth (a phenomenon known as "apogee dwell"). During the brief time
the satellite is below the local horizon, a hand-off to another satellite in the same orbit is required in order
to avoid loss of communications. Free space loss and propagation delay for this type of orbit are
comparable to that of geosynchronous satellites. However, due to the comparatively great movement of a
satellite in HEO relative to an observer on the Earth, satellite systems using this type of orbit must cope
with large Doppler shifts. Examples of HEO systems are:

• the Russian Molniya system, which employs three satellites in three 12-hour orbits separated by
120 deg around the Earth, with an apogee of 39,354 km and a perigee of 1000 km.

• the Russian Tundra system, which employs two satellites in two 24-hour orbits separated by 180
deg around the Earth, with an apogee of 53,622 km and a perigee of 17,951 km.

• the proposed Loopus system, which employs three satellites in three eight-hour orbits separated
by 120 deg around the Earth, with an apogee of 39,117 km and a perigee of 1238 km.

• the European Space Agency's (ESA's) proposed Archimedes system, employing a so-called "M-
HEO" eight-hour orbit with three apogees spaced at 120 deg, each corresponding to a service
area covering a major population center (e.g., Europe, the Far East and North America).
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Activity 4: Create a Geostationary Orbit (GEO) Satellite

Defining a Satellite

1. Insert a new Satellite. If the Orbit Wizard doesn't appear automatically, select Orbit Wizard
from the Tools menu. Click Next to go to the second screen, and select Geostationary. Click Next
again. In the third window of the Orbit Wizard, set Subsatellite Longitude to -80 deg, then click
Next. In the fourth window, click Finish to propagate the orbit.

2. Name the new satellite GEO.

Note: Remember to save the scenario periodically.

Geosynchronous & Geostationary Orbits

A geosynchronous orbit is defined as an orbit with a period of one sidereal day (1436.1 minutes). A
geostationary orbit is a special case of a geosynchronous orbit with zero inclination and zero eccentricity,
i.e., an equatorial, circular orbit. A satellite in a geostationary orbit appears fixed above a location on the
surface of the Earth. In practice, a geosynchronous orbit typically has small non-zero values for inclination
and eccentricity, causing the satellite to trace out a small figure eight in the sky. The footprint or service
area of a geosynchronous satellite covers almost one-third of the Earth's surface (from about 75 deg
South to about 75 deg North latitude), so that near-global coverage can be achieved with as few as three
satellites in orbit. A disadvantage of a geosynchronous satellite in a voice communication system is the
round-trip delay of approximately 250 milliseconds.

A Polar Orbit

The plane of a polar orbit is inclined at about 90 deg to the equatorial plane, intersecting the North and
South poles. The orbit is fixed in space, and the Earth rotates underneath. Thus, in principle, the coverage
of a single satellite in a polar orbit encompasses the entire globe, although there are long periods during
which the satellite is out of view of a particular ground station. This gap in coverage may be acceptable for
a store-and-forward communications system. Accessibility can, of course, be improved through the
deployment of two or more satellites in different polar orbits.

Most small LEO systems employ polar or near-polar orbits. An example is the COSPAS-SARSAT Maritime
Search and Rescue system, which uses eight satellites in near polar orbits: four SARSAT satellites moving
in 860 km orbits inclined at 99 deg (which makes them Sun-synchronous) and four COSPAS satellites
moving in 1000 km orbits inclined at 82 deg.

A Sun-Synchronous Orbit

In a Sun-synchronous or helio-synchronous orbit, the angle between the orbital plane and Sun remains
constant, resulting in consistent light conditions for the satellite. This can be achieved by careful selection
of orbital altitude, eccentricity and inclination, producing a precession of the orbit (node rotation) of
approximately 1 deg eastward each day, equal to the apparent motion of the Sun. This condition can be
achieved only for a satellite in a retrograde orbit. A satellite in Sun-synchronous orbit crosses the equator
and each latitude at the same time each day. This type of orbit is therefore advantageous for an Earth
observation satellite, since it provides constant lighting conditions.
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Activity 5: Observe Differences among Orbit Types

1. Click the Animate Forward button to animate the scenario. Observe the satellites as they move

along their ground tracks. Click Reset when finished.

2. Highlight one of the satellites in the Object Browser, then right-click and select Satellite Tools --
> Report. When the Report window appears, choose a report style that interests you and click
Create....

3. Explore the different report types available to you. When you finish, close all reports, then click
Cancel in the Report window.

4. Now open the Satellite Tools-->Graph window for one of the satellites. When it appears,
choose a style of interest and click Create.

5. In the Graph window, use the Zoom In and Zoom Out buttons to change the magnification
levels. When you are finished, close all graphs, then click Cancel in the Graph window.

6. Repeat the steps above for the other satellites you created. Note the different characteristics of
each orbit type as reflected in the reports and graphs.

7. In the Object Browser window, select all the satellites by highlighting the top one (GEO), holding
down the Shift key and clicking the last one in the list (MEO). Recreate both graphs and reports.
The selected graph or report will now show the data for all four satellites.

8. Now open the Basic/Orbit page for different satellites. Change some of the Keplerian elements
and note differences in the ground tracks when you click Apply and/or animate the scenario.
Return all satellites to their original properties when you are finished.

9. In the Object Browser window, highlight Orbits and select Save, then Close in the File menu.


