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Exercises using Satellite ToolKit (STK)
vivarad@ait.ac.th

STK Familiarization Exercise

What You Will Do

• Create satellites and define their basic and graphics properties
• Generate satellite accesses, reports, swaths and display lighting conditions
• Define facility access and constraints
• Define sensor attributes and analyze sensor access

• Create a report, graph, dynamic display and strip chart

What You Will Learn

STK is a multifaceted tool designed for aerospace professionals. This exercise demonstrates its many
powerful features, along with its dynamic flexibility of use.

Here, you will begin to walk through some of the many capabilities of STK: creating objects, determining
access and creating output, such as reports and graphs. The advanced user as well as the new user will
get a good overview of STK's potential from working this exercise.

Activity 1: Creating the Basics Scenario

1. Highlight the basics scenario in the Object Browser window, right click, select the Properties
Browser and go to the Basic/Time Period page.

2. On the Time Period page, set the following options:

Field Value

Start Time 1 Jan 2000 00:00:00.00

Stop Time 2 Jan 2000 00:00:00.00

Epoch 1 Jan 2000 00:00:00.00

Note: Each scenario has a time period and an epoch. The time period defines the
general time span for analysis. The epoch serves as a reference for all other times
in the scenario.

3. On the Animation page, set the following options:

Field Value

Start Time 1 Jan 2000 00:00:00.00

Loop At Time 2 Jan 2000 00:00:00.00

Time Step 60 sec

Refresh Mode High Speed
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Note: You may have to change your default Field settings before being able to
change the associated values. For example, you may have to change "End Time"
to "Loop at Time".

4. On the Units page, set the following options:

Units Change Unit Value

Distance Unit Kilometer (km)

Time Unit Seconds (sec)

Date Format Gregorian UTC (UTCG)

Angle Unit Degrees (deg)

Mass Unit Kilograms (kg)

Note: You can double click on the CurrentUnit to see the available options.

5. Select the Description page and, in the Short Description field, type:

My Basics Scenario

6. When you finish, click OK.

7. Make the 2-D window active and open it's Properties.

8. On the Lighting page, select Show Subsolar Point, and select Show Outline for both Penumbra
and Umbra. Change Penumbra and Umbra outline colors if desired and click OK.
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Activity 2: Populate the Scenario with Satellites

Defining Satellites

In this activity we'll create two satellites and work with their graphics properties. First, we'll create a
satellite orbit by entering its basic properties. Then we'll use the Orbit Wizard to propagate a satellite
orbit and take a look at some different Graphics Properties available to the user in STK. We'll look at
different line styles, visible sides of the orbit, ground track lead types, lighting styles and swath options.

1. From the Insert Menu, click New and select the Satellite icon from the Object Catalog, click
Insert, and name it leo. If the Orbit Wizard appears, click Cancel to dismiss it.

2. Right click the leo satellite, select Properties Browser and go to the Basic/Orbit page

Note: Click the down-pointing arrow to the right of the Semimajor Axis field to
change the parameter type for the first Keplerian element to Apogee Altitude.
Similarly, change RAAN to Lon. Ascn. Node (longitude of ascending node).

3. Enter the following values into the Orbit page:

Field Value

Propagator J4 Perturbation

Start Time 1 Jan 2000 00:00:00.00

Stop Time 2 Jan 2000 00:00:00.00

Step Size 60 sec

Apogee Altitude 600 km

Perigee Altitude 600 km

Inclination 75 deg

Argument of Perigee 0.0 deg

Lon. Ascn. Node 10 deg

True Anomaly 0 deg

4. When you finish, click OK.

5. Highlight the basics scenario in the Object Browser, from the Insert Menu, click New and select
the Satellite icon from the Object Catalog, and click Insert. If the Orbit Wizard doesn't appear
automatically, select it from the Satellite --> Orbit Wizard menu.

6. Click Next to go to the second screen, select Repeating Ground Trace and click Next again.

7. In the third window of the Orbit Wizard, set the following options:

Option Description

Approximate Revs Per Day 4

Inclination 45 deg

Number of Revs to Repeat 4

Longitude of First 5 deg
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Ascending Node

8. Click Next again and set the following options:

Option Description

Orbit Start 1 Jan 2000 00:00:00:00

Orbit Stop 2 Jan 2000 00:00:00:00

Time Step 60.00 sec

9. Click Finish when you are done.

10. Rename the new satellite meo.

11. Click the Animate Forward button to animate the scenario. Switch to the 2-D and 3-D windows
to view the animation.

12. When you finish, click the Reset button

Satellite Pass

You can control the appearance of the satellite's ground track and orbit path.

1. Open the Properties Browser for the leo satellite.

2. Go to the 2D Graphics/Pass page and enable Show Pass Labels.

3. Click Apply to see your changes in the 2-D Map Window. Each groundtrack now has the
associated pass shown.

4. Change Visible Sides to Ascending and click Apply. Click the Animate Forward button to see the
changes.

5. Now change Visible sides back to Both and change the Leading/Trailing Ground track Lead Type
to Half. When you finish, click Apply.

6. Animate the scenario to see the effect of the change.

7. Reset the Leading/Trailing Ground Tracks Lead Type to All and disable the Show Pass Labels.
Click OK.

Satellite Lighting

You can display lighting conditions for individual satellites in the 2-D window.

1. Open the Properties Browser for the meo satellite.

2. On the 2D Graphics/Lighting page, turn on the Sunlight, Penumbra, and Umbra options and
set other options as follows:
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Line/Marker Style Color Line Width

Sunlight Blue medium

Penumbra White medium

Umbra Red medium

3. Apply changes and observe 2-D Map window. Magnify the ground track at the transition point

to see the Penumbra. Zoom out to full view.

4. Enable Show Sunlight/Penumbra Boundry at Vehicle Altitude and click Apply. Reset and then
animate the scenario.

5. Remove all Lighting options and click OK to dismiss the page.

Satellite Swath

The satellite swath displays field-of-view areas for a selected ground elevation angle or for a half angle
relative to nadir or a surface distance. Swaths can be viewed with either the Edge Limits of the field-of-
view shown, or the whole viewable area shaded. In this section, we will see both.

1. Open the Properties Browser for the meo satellite.

2. Go to the 2D Graphics/Swath page for the meo satellite and set the Ground Elevation to 60
deg. Select Edge Limits and click Apply to view changes in the Map window.

3. Now, select Filled Limits and click Apply. Notice the changes in the 2-D window. You can now see
the entire field-of-view area represented by the shaded area.

4. Change Ground Elevation Angle to 80 deg and Apply.

5. Return the Swath page to its original state (No Graphics) and click OK.
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Activity 3: Working with Facilities

Facilities are objects that are defined as stationary locations on the Earth's surface. They are flexible in
function, since they can be used to represent ground stations, launch sites, tracking stations, or other
structures providing satellite support.

1. Highlight the basics scenario in the Object Browser window. Click on the Insert menu, select
New..., select facility, and click Insert. Rename the facility socal.

2. From the Properties Browser for socal, open the Basic/Position page. Enter the facility's
exact position as follows:

Option Description

Type Geodetic

Latitude 33 deg

Longitude -117 deg

Altitude 0.000 km

3. Click OK.

4. Create a second facility and rename it cape_canaveral.

5. From the Properties Browser for cape_canaveral, open the Basic/Position page. Enter the
facility's exact position as follows:

Option Description

Type Geodetic

Latitude 28.5 deg

Longitude -81 deg

Altitude 0.000 km

6. Click OK. The new facility appears in the map window at the specified location.
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Activity 4: Determine Access & Apply Constraints

By determining accesses, you can find out when one object can see another object. In addition, you can
impose constraints on accesses between objects to define what circumstances allow access. These
constraints are defined as properties of the objects between which accesses are being calculated.

1. Highlight the socal facility in the Object Browser window. Select Access from the Facility heading
on the menubar.

2. Select the leo satellite from the Associated Objects and click the Access... button in the Reports
section. This will generate both the Access and the Report. Notice the groundtrack changes in the
Map window, they are highlighted where the two objects have access.

Quiz: How many seconds in duration is the total access period between the
satellite and the facility?1

3. Minimize the Access report for later use.

4. With socal still highlighted in the Object Browser window, from the Properties Browser select
the Constraints/Basic page. Enable the Minimum Elevation Angle and set to 10 deg.

5. Click Apply. Notice how the Access graphics change in the Map window.

Note: Constraints limit the time when two objects are "in-view" of each other
using different conditions. In this example, the leo satellite can only be viewed
from the socal facility when it is at least 10 degrees above the horizon.

6. Resize the report. In the Report window, select Refresh from the File menu and notice the change
in access duration.

Quiz: What is the total access period now?

7. In the Constraint/Basic page, turn off the Min Elevation constraint and Click OK.

8. Close the report and click the Remove All button in the Access window. Close the Access window
by clicking Close.

Answer 1: The total access is approximately 2856 seconds.

Answer 2: The new duration due to the constraint is approximately 1522
seconds.
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Activity 5: Add a Planet to the Scenario

The inclusion of planets and stars are often necessary to provide a complete analysis of sensor in-view
opportunities. In STK, planets represent objects in heliocentric orbit (as well as the Earth's Moon and the
Sun itself). Stars are used to represent "stationary" celestial objects.

1. Highlight the basics scenario in the Object Browser window. Click on the Insert menu, select
New..., select Planet, and click Insert.

2. Open the Properties Browser window for the new planet. On the Basic/Definition page,
select Moon as the Central Body, and select DE405 as the Ephemeris Source.

3. Click OK to apply the changes and close the window. Notice the planet is automatically renamed
to Moon.

4. Reset the animation, and then animate the scenario. Notice the Moon's subplanet point is
displayed. This is the location on the Earth that the Moon is directly above.
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Activity 6: Add Sensors to the Scenario

Sensors can be used to represent such equipment as optical or radar sensors, receiving or transmitting
antennas, or lasers. They can also be used to define another object's field of view. Although sensors are
objects, they are subordinate to, or sub-objects of, the parent object to which they are attached.

1. Highlight the leo satellite in the Object Browser window. From the Insert Menu, click New and
select the Sensor icon from the Object Catalog, and click Insert. Rename the sensor image.

2. Right click the image sensor, select Properties Browser, go to the Basic/Definition page, and
set the values as follows:

Option Description

Sensor Type Simple Conic

Cone Angle 80.00

3. When you finish, click OK.

4. Create another sensor for the leo satellite, and rename it track. Open the Properties Browser
page for the sensor, and on the Basic/Definition page, define the Sensor Type as Simple Conic
with a cone angle of 35 deg.

5. On the Basic/Pointing page for the track sensor, set the following options:

Option Description

Pointing Type Targeted

Boresight Type Tracking

6. Highlight the socal facility in the Available Targets list and check the box to assign it as a target.
Repeat this process for the cape_canaveral facility

7. When you finish, click Apply.

8. On the 2D Graphics/Attributes page change the color to be different from that of the
previously created image sensor and click OK. This will help when viewing the sensor in the map
window.

9. Animate the scenario. Notice that when the satellite gets within range of either facility, the track
sensor pattern appears. The pattern of the image sensor, which is non-tracking, is always
displayed.

10. Create a sensor for the socal facility and rename it uplink.

11. Right click the uplink sensor, select Properties Browser, go to the Basic/Definition page,
define the sensor as Simple Conic with a Cone Angle of 80 deg. Click Apply.

12. Go to the uplink sensor's 2D Graphics/Projection page. For "Project to:" select Object Altitude,
and then select the leo satellite under Projection Altitude Object. Click OK. This sets the altitude
of the sensor's projection to the height of the leo satellite.

13. Reset and animate the scenario to observe the sensor display over time in the 2D map window.
Reset the scenario when finished.
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Activity 7: Compute Sensor Access

Previously we computed access between satellites and facilities. We will now calculate access for some of
the other objects that we have created.

1. Highlight the image sensor in the Object Browser, right click and select Sensor Tools -->
Access from the menu.

2. Highlight both the socal and cape_canveral facilities and click the compute access button.

3. The 2D Map window updates to display the access as the highlighted portion of the ground track.

4. To view a report of the access time, click on the Access... button in the Reports column. A report
listing the access times between the objects displays.

5. Note the intersection of the sensor pattern and the cape_canaveral facility.

6. Close the report

7. Click the Remove Access button and click Close to close the window. Reset the 2-D Map window.

8. Highlight the uplink sensor and open the Access tool.

9. In the Available Object list, select moon.

10. Click on the Access... button in the Reports box.

Quiz: How long is the Access time between the sensor &
the moon?3

11. Close the report and click the Remove All button in the Access window.

12. Click Close to close the window.

Answer 3: The two objects have access for approximately 34014 seconds.back
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Activity 8: Create Reports and Graphs

STK comes with a wide variety of standard report styles to choose from, for example: LLA (Longitude,
Latitude & Altitude) Position, Classical Orbit Elements, and ECF Position Velocity. STK also allows you the
freedom to create custom reports to meet your own specific needs. Here we will create some standard
reports and graphs and learn about dynamic displays and strip charts.

Creating Reports

1. In the Object Browser window, select the meo satellite.

2. Go to the Satellite --> Report menu.

3. In the Styles list, select ECF Position Velocity and click the Create button.

4. After reviewing the report close it and the Report tool window.

Warning: It is recommended that you not make changes to default styles. Instead
either make a copy of an existing style to modify, or simply create a new style.

Creating Graphs

1. In the Object Browser window, select the leo satellite.

2. Go to the Satellite --> Graph menu.

3. In the Styles list, select Solar AER and click the Create button.

4. After reviewing the graph close it and the Graph tool window.

Dynamic Display of Data

1. In the Object Browser window, select the meo satellite.

2. Go to the Satellite --> Dynamic Display menu.

3. In the Styles list, select LLA Position Style and click the Open button. A Dynamic Display window
will open. If your windows are maximized such that you can only see one window at a time,
restore and size them so you can see the Dynamic Display window and the 2-D and 3-D windows.

4. Click the Animate Forward button.

5. Notice how the Dynamic Display changes to display the current latitude, longitude and altitude

position for the satellite. Pause the animation so that you can read the values.

6. When you finish, reset the animation.

7. Close the Dynamic Display window and the Dynamic Display Tool.
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Strip Chart

1. In the Object Browser window, select the meo satellite.

2. Go to the Satellite --> Strip Chart menu.

3. In the Styles list, select LLA Position Style and click the Open button. A Strip Chart window will
open. Again, restore and size the windows so you can see the Strip Chart window and the 2-D
and 3-D windows.

4. Click the Animate Forward button.

5. Notice how the Strip Chart changes to display the current latitude, longitude and altitude position
for the satellite. Again, Pause the animation to see the values.

6. When you finish, reset the animation.

7. Close the Strip Chart window and the Strip Chart Tool.


